Back to overview
Degraded

API Degradation Due To Ongoing AWS Incident

Oct 20 at 12:00pm EDT
Affected services
Datalab API

Resolved
Oct 20 at 02:03pm EDT

Datalab's API has stabilized after mitigations we have put in place.

The AWS incident is ongoing. We are actively monitoring the situation in case it triggers issues with our API again.

Created
Oct 20 at 12:00pm EDT

Our API is currently degraded and seeing high failure rates due to ongoing AWS issues affecting our upstream providers, Modal and Render.

Today's AWS incident is ongoing: https://health.aws.amazon.com/health/status.